[FreeBSD] ports 安裝舊版本 (以 ImageMagick 為例)

Standard

最近需要用到 ImageMagick,而 ports 上最新的版本是 6.6.0-10 ,但似乎安裝過程中會 make 失敗,所以試著安裝舊的版本。

首先要修改 ports-supfile,在 *default 下多增加一行欲更新軟體版本推出的時間,可以去 http://www.freshports.org 查詢,以本例來說,我想安裝 6.5.7.10 版,推出的時間為 02 Dec 2009 18:54:03,我可以輸入:

[code]
*default date=2009.12.03.00.00.00
[/code]

接著把 ports-all 先 mark 掉,然後把欲安裝軟體所屬的分類啟用,以本例來說是:ports-graphics。
都設定好後,用 csup 跑一次 ports tree 更新。

接著再去該軟體 ports 目錄下 make install 就可以了~

發表迴響

你的電子郵件位址並不會被公開。 必要欄位標記為 *